Bug #902

Scheduled downtimes not displayed after restart

Added by mlausch over 3 years ago. Updated over 3 years ago.

Status:ResolvedStart date:10/15/2010
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Other
Target version:-
Icinga Version: Browser Version:

Description

Hello,

I think there is an Problem with the display from scheduled downtimes in the status.cgi and extifno.cgi.

If I enter an downtime I will see the downtime comment and an downtime icon. At an restart from Icinga the Downtimes are reread out of the retention.dat. I can see them in the downtime Menü (extinfo.cgi?&type=6) and it seems they work correctly, too. But in the status.cgi there is only the comment and not the downtime icon. In the Detailed infos (extinfo.cgi?type=2&host=xy&service=Used+Mem) at the Line "In Scheduled Downtime?" there is displayed "no" as well.

The Problem is, Tools like nagstamon or the nagios-checker plugin from firefox cant see if an Host or Service is in scheduled downtime and alerts the warning.

The Version of Icinga I use is 1.2.0

I hope you can reproduce my Problem and will fix it.

Manuel Lausch

History

#1 Updated by dnsmichi over 3 years ago

  • Status changed from New to Feedback

i think that's related to that fix #584

can you recheck on the current master? it has been reported as fixed and working already.

https://dev.icinga.org/issues/584#note-11

#2 Updated by mlausch over 3 years ago

Thank you!

This solved my problem.
When will it officially release? Because an git checkout is not the best variant in an productive Environment.

#3 Updated by dnsmichi over 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

thanks for reporting back! :)

yeah that would need 1.2.1 and we are already planning on that. next week if possible.

Also available in: Atom PDF