Bug #737

Can't save anything on the Admin interface

Added by elagon over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:08/19/2010
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:1.2 (Stable)
Icinga Version: DB Type:
Icinga Web Version: DB Version:
IDO Version: Browser Version:
OS Version:

Description

I've got a serious bug with firefox and the new web interface: whenever i edit (or create a new) an item (eg a user or a group) and the setting windows pop up, if I press the save button nothing happens (whell, if I miss write some required fields I receive the allert, so in a way clicking it works, but when all fields are ok nothing more happens). Using Safari, Chrome and Internet Exploder works fine. The problem is with Firefox on Mac OS X ,Linux Ubuntu Desktop 10.04 and Windows XP

Icinga_Web_Bug.mp4 (1.1 MB) elagon, 08/19/2010 12:01 pm

History

#1 Updated by elagon over 3 years ago

Here is a screen recording of the bug

#2 Updated by elagon over 3 years ago

Forgot the version: 1.0.3

#3 Updated by jmosshammer over 3 years ago

Do you have any messages in the error console/firebug?

#4 Updated by elagon over 3 years ago

well, this is ridiculous, I have done nothing, not even a reboot of firefox and now works again...
Tomorrow I will try again

#5 Updated by jmosshammer over 3 years ago

Fixed in current master.
Only occured in FF when no firebug was installed, because he said console is undefined when logging (in the code that checks if console is defined, strange behaviour).

Put a try/catch around it to absolute be sure that the logging mechanism never ever can't screw up the site.

#6 Updated by jmosshammer over 3 years ago

  • Status changed from New to Resolved

#7 Updated by elagon over 3 years ago

  • Status changed from Resolved to Feedback

On the last master it doesn't work...

#8 Updated by jmosshammer over 3 years ago

Try clearing your cookies/cache, perhaps the old javascript code is in the cache.

Does it work afterwards?

#9 Updated by elagon over 3 years ago

My firefox is set to reset everything everytime I close it.
But to be sure I just cleared everything manually.
I also tried from a new fresh computer I never used to access and still it doesn't work

#10 Updated by jmosshammer over 3 years ago

What does the FF error console tell you after you click on save?
When you click on the line to see the js code, what block of code does he display?

Unfortunately, I cannot reproduce it. I just checked it on another system and it worked there as well as on my system.

Thx for testing.

#11 Updated by elagon over 3 years ago

Here is the error

Error: console is not defined
Source File: http://monitor.wavegroup.it/icinga-web/appkit/squishloader/javascript
Line: 157

#12 Updated by Infinity over 3 years ago

Same here, does not work with firefox, even when trying to inPrivate browsing, can't find anything in the error console since it looks like there's a bug also in the console.log (firebug implementation or sth)

Works fine in Chrome.

#13 Updated by jmosshammer over 3 years ago

  • Target version set to 1.2 (Stable)

Could you try the new master and remove all cookies and caches before opening icinga-web?
Since my last comment I tried a whole bunch of VM's and other systems and the error didn't occur with the version I commited.

#14 Updated by jmosshammer over 3 years ago

  • Status changed from Feedback to Closed

As I couldn't reproduce it on any device I tried since the last udpate I'm closing this ticket. Feel free to reopen it if it occurs again (which should be very unlikely)

Also available in: Atom PDF