Bug #577

re-schedule service using wrong command in form - wrong error about missing authorization

Added by dnsmichi almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:07/08/2010
Priority:NormalDue date:
Assignee:dnsmichi% Done:

0%

Category:-
Target version:-
Icinga Version: Browser Version:

Description

/cgi-bin/cmd.cgi?cmd_typ=7&host=test_host_000&service=test_ok_01&force_check

rescheduling a service check not on e.g. test_ok_01 but test_ok_* fails (using a regex in the service form, something that the cgis cannot reproduce).

failing is expected, but the error output says sth about authorization, which is completely wrong.

Sorry, but you are not authorized to commit the specified command.

Read the section of the documentation that deals with authentication and authorization in the CGIs for more information.

Return from whence you came

History

#1 Updated by dnsmichi over 3 years ago

  • Project changed from Core to Classic UI
  • Category deleted (Classical UI)

#2 Updated by TheFlyingCorpse over 3 years ago

I checked up the logic and the CGI's assume you dont have permission when "you" cant see them.

#3 Updated by dnsmichi over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to TheFlyingCorpse

but before checking the permissions, there should be an output that this host/service does not exist? because a user never will be authorized to see sth which does not exist ;)

pls check on this.

#4 Updated by dnsmichi over 3 years ago

  • Assignee changed from TheFlyingCorpse to dnsmichi
  • Target version set to 1.3

#5 Updated by dnsmichi over 3 years ago

  • Status changed from Assigned to Closed
  • Target version deleted (1.3)

given the fact that ricardo re-implemented the view, the cmd.cgi now does not attract the view on "you are not authroized, go away", but inot a general error, seeing a wrong hostname and not being authorized for it.

that should be fine, i'm closing this for now.

Also available in: Atom PDF