Bug #540

potential bug in distributed environments: passive checks are checked actively

Added by mstreb almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:06/25/2010
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Distributed
Target version:-
Icinga Version: OS Version:

Description

under some, actual not known circumstances the following is happening:

in an distributed environment the central instance which is just accepting passive checks is executing active servicechecks even if active_checks_enabled is set to 0.
In this case also the retention file is not showing any setting which is enabling the active checks.

has anybody an idea how this could happen, neither freshness checking nor an dependency is configured for this service.

History

#1 Updated by dnsmichi almost 4 years ago

is it possible that the template used for this service has active_checks_enabled? this is the only condition matching regarding config parsing.

#2 Updated by mstreb almost 4 years ago

nop, i checked this more than once.
also in objects.cache its set to 0

but maybe it has something to do with the check_freshness stuff i will recheck this.

-> this is why i opened a potential bug report. :)

mstreb

#3 Updated by Meier almost 4 years ago

To log freshness debug info set debug_level to 16 (DEBUGL_CHECKS) and debug verbosity to 1 or 2.

#4 Updated by dnsmichi almost 4 years ago

  • Category changed from Other to Distributed

#5 Updated by dnsmichi over 3 years ago

  • Priority changed from Normal to Low

any updates on that?

#6 Updated by mstreb over 3 years ago

  • Status changed from New to Closed

yep as always: the problem is behind the display
-> global freshness checking was enabled.

Issue an be closed, i totally forgot about that

Also available in: Atom PDF