Bug #3313

configure not supporting AM_INIT_AUTOMAKE

Added by jschanz over 1 year ago. Updated over 1 year ago.

Status:ResolvedStart date:10/19/2012
Priority:NormalDue date:
Assignee:dnsmichi% Done:

100%

Category:Installation
Target version:Icinga 1.x - 1.8.1
Icinga Version:1.8.0 DB Version:1.8.0
DB Type:MySQL Jasper Version:4.7.0

Description

Configure of icinga-reports-1.8.0 throws the following error:

root@localhost:/usr/src/icinga-reports-1.8.0# ./configure --with-jasper-server=/opt/jasperreports-server-cp-4.7.0
./configure: line 1682: AM_INIT_AUTOMAKE: command not found
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for jasperserver... configure: creating ./config.status
config.status: creating Makefile

The fix provided in Bug #2623 works here too -> https://git.icinga.org/?p=icinga-reports.git;a=commit;h=c4e2d2b686eada065066b36bf5080640e0f58cbf

root@localhost:/usr/src/icinga-reports-1.8.0# rm configure
root@localhost:/usr/src/icinga-reports-1.8.0# aclocal
root@localhost:/usr/src/icinga-reports-1.8.0# autoconf
root@localhost:/usr/src/icinga-reports-1.8.0# ./configure --with-jasper-server=/opt/jasperreports-server-cp-4.7.0
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for jasperserver... configure: creating ./config.status
config.status: creating Makefile

Maybee it's better to provide an install.sh for this which creates the configure script in the local environment.


Related issues

Duplicated by Reporting - Bug #3424: @INSTALL@ will not be found Closed 11/06/2012

Associated revisions

Revision 4d63ea7b
Added by dnsmichi over 1 year ago

wipe AM_AUTOMAKE_INIT, and recreate configure once again (fixes #3313)

History

#1 Updated by dnsmichi over 1 year ago

  • Status changed from New to Assigned
  • Assignee set to dnsmichi
  • Target version set to 1.8.1

#2 Updated by dnsmichi over 1 year ago

  • Subject changed from It seems, Bug #2623 is also present in Icinga Reporting 1.8.0 to configure not supporting AM_INIT_AUTOMAKE

#3 Updated by dnsmichi over 1 year ago

AM_AUTOMAKE_INIT isn't used at all, so why keeping it.

#4 Updated by dnsmichi over 1 year ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF