Bug #2573

Commands dropdown cannot be used repetitive

Added by mario@rimann.org over 3 years ago. Updated 9 months ago.

Status:ClosedStart date:05/01/2012
Priority:NormalDue date:
Assignee:mario@rimann.org% Done:

0%

Category:Classic UI
Target version:-
Icinga Version:1.10.0 OS Version:any

Description

When watching a list of services (e.g. http://[byIcingaServer]/icinga/cgi-bin/status.cgi?host=all&type=detail&servicestatustypes=29), I cannot select single services to e.g. force a re-check more than once in a row.

Steps to reproduce:
- visit that page (which must show 2 or more entries at least)
- mark the checkbox of one of the listed entries
- select "Re-Schedule Next Service Check" from the commands dropdown just above the checkbox-column
- click the submit button below the dropdown menu
- on the page that gets shown, confirm the re-scheduling by clicking "commit"
- on the confirmation page that gets shown, click "Done" which brings you back to the list that was shown at the beginning
- (note that the checkbox is still set at this service)
- now checking another service from the list to re-schedule it's next check is impossible since the entry "Re-Schedule Next Service Check" is already selected in the commands dropdown and the submit button is disabled.


Related issues

Duplicates Core, Classic UI, IDOUtils - Bug #2117: reset forms on return after submitting command Resolved 11/24/2011

History

#1 Updated by dnsmichi over 3 years ago

please show

git log -1

#2 Updated by ricardo over 3 years ago

Hi,

this behavior changes with 1.7. The checkboxes and the DropDown menu get's reseted then. Because it depends on the type of browser where the checkboxes are still selected or not.

please check with current git master and test it if you can.

Cheers Ricardo

#3 Updated by dnsmichi over 3 years ago

  • Status changed from New to Feedback
  • Assignee set to mario@rimann.org

#4 Updated by mario@rimann.org over 3 years ago

Well I've seen this behaviour in a 1.6.x installation - so this bug report might be outdated already.

Please close this issue then.

#5 Updated by dnsmichi over 3 years ago

try an icinga snapshot build for 1.7 :-)

http://build.icinga.org/snapshots/

#6 Updated by dnsmichi over 3 years ago

  • Status changed from Feedback to Closed

#7 Updated by dnsmichi 9 months ago

  • Project changed from 19 to Core, Classic UI, IDOUtils
  • Category changed from 52 to Classic UI
  • Icinga Version set to 1.10.0
  • OS Version set to any

Also available in: Atom PDF