Bug #2523

Applying changes to many hosts

Added by chjohnst about 2 years ago. Updated almost 2 years ago.

Status:ResolvedStart date:04/14/2012
Priority:NormalDue date:
Assignee:mhein% Done:

100%

Category:Interface Features
Target version:Icinga 1.x - 1.7
Icinga Version: DB Type:
Icinga Web Version: DB Version:
IDO Version: Browser Version:
OS Version:

Description

If I have multiple hosts show up with a failed service, if I want to acknowledge all of them at once (click the bread crumb, etc) and then acknowledge it is only applying the acknowledgement to a single host when it should be applying to all. I think this is a bug. Same thing happens for downtime as well and other commands.

icinga_web_hostlist_ack_command_svc_cmd_wrong_sent.png (66.5 KB) dnsmichi, 04/30/2012 08:47 pm


Related issues

Related to Web - Bug #2572: host status command ack with expiry time sending svc cmd ... Resolved 04/30/2012
Related to Web - Bug #2406: Add comment for several hosts/services no possible Closed 03/06/2012
Related to Web - Bug #2454: Problem with multiple selection in icinga-web. Closed 03/19/2012
Related to Web - Bug #2416: External Commands - Multi selection doesnt work Closed 03/08/2012

History

#1 Updated by mhein about 2 years ago

  • Target version changed from 1.6.2 to 1.7

#2 Updated by mhein about 2 years ago

Scheduled for 1.7. Please do a cherry-picking downstream into r1.6.

#3 Updated by ossmon about 2 years ago

I think, same as #2406 and #2454

#4 Updated by Frankstar about 2 years ago

should be fixed ??
https://dev.icinga.org/issues/2416

which version did you use ?

#5 Updated by mhein about 2 years ago

  • Assignee set to mhein

#6 Updated by dnsmichi almost 2 years ago

that's not fixed.

for some awkward reason the host list and host ack with expiry time sends a service command ?!

Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;localhostv6;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'localhostv6' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;localhostv6-flexible;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'localhostv6-flexible' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_1;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_1' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_2;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_2' and service '0' provided in external command!
Apr 30 20:43:40 icinga-dev icinga: EXTERNAL COMMAND: ACKNOWLEDGE_SVC_PROBLEM_EXPIRE;test_router_3;0;0;0;1335812009;root;fdgdfgdga
Apr 30 20:43:40 icinga-dev icinga: Error: Could not find host 'test_router_3' and service '0' provided in external command!

#7 Updated by dnsmichi almost 2 years ago

see #2572 - fixed over here. now let's see for the rest.

#8 Updated by dnsmichi almost 2 years ago

  • Status changed from New to Resolved
  • Priority changed from High to Normal
  • % Done changed from 0 to 100

ok works for me, as this is a duplicate of various issues as well, and the wrong command is a seperated issue.

Also available in: Atom PDF