Bug #1984

Insert of comments with german characters (Umlaute) produce an 'Authentication failed'

Added by ossmon over 2 years ago. Updated over 1 year ago.

Status:ClosedStart date:10/07/2011
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Icinga Version:1.6.1 DB Type:MySQL
Icinga Web Version:1.6.1 DB Version:5.1.61
IDO Version:1.6.1 Browser Version:any
OS Version:any

Description

When we try to add comments to a service and the comment contains german special characters (Umlaute: for example ä or ü), it failed with an 'Authentication failed' popup window in icinga-web.
It doesn't matter if persistent or not.
In the debug file of the icinga-web there is:
[Fri Oct 7 15:56:13 2011] [info] SendCommandAction: Prepare to send command (command=ADD_SVC_COMMENT)
[Fri Oct 7 15:56:13 2011] [debug] SendCommandAction: Authentification failed! (hmac=8f409741af4fb7b274abe8f160ad50d9d7413380)

Associated revisions

Revision 8273f720
Added by jmosshammer about 2 years ago

  • Fixed umlauts not working in commands (fixes #1984)

History

#1 Updated by smarx over 2 years ago

The same thing happens in the comment fields for scheduling host or service downtimes or acknowledging problems.

#2 Updated by tgelf about 2 years ago

I can confirm that this is still an issue in 1.6.1.

#3 Updated by jmosshammer about 2 years ago

  • Status changed from New to Closed

fixed in master

#4 Updated by fr3ddie over 1 year ago

Hello,

I believe the bug should be reopened because the patch only works for German umlauts: if I try to insert, for instance, the character "ğ" (Turkish one) into a comment I have the same behaviour reported before this patch and receive the same error ("Authentication Failed").
Tested on icinga-web v1.6.2 AND v1.8.1.
Please provide a simple patch also for v1.6.2, I can't upgrade at the moment ;)

Please contact me if I can provide any help,
thank you.

#5 Updated by dnsmichi over 1 year ago

  • Icinga Version set to 1.6.1
  • Icinga Web Version set to 1.6.1
  • IDO Version set to 1.6.1
  • OS Version set to any
  • DB Type set to MySQL
  • DB Version set to 5.1.61
  • Browser Version set to any

the original issue was for german umlauts, if you find anything else being an umlaut and not working, please open a new issue with relation to here then, thanks.

Also available in: Atom PDF